Меню

настройка роутера mikrotik как репитера

Оборудование в режиме репитера

Нередки случаи, когда необходимо развернуть сеть на значительной территории, при этом объединить оборудование с помощью кабелей по какой-либо причине не представляется возможным. В данной ситуации для усиления сигнала Wi-Fi сети неплохим подспорьем может выступить вариант с репитером. Оборудование, настроенное в режиме повторителя, принимает сигнал от главного роутера и раздает его дальше, таким образом охватывая территорию, «недоступную» основной точке.

Важное уточнение: режим репитера имеет серьезный недостаток – скорость Wi-Fi может упасть до 50%

В этой статье на примере работы двух микротиков расскажем, как настроить оборудование в режиме репитера.

Стоит учесть, что необходимый для данного режима пакет был добавлен в RouterOS версии 6.35, поэтому не забудьте обновить Mikrotik (System — Packages — Check for Updates).

Берем в расчет, что у вас уже настроен основной миркотик и на нем создан беспроводной интерфейс (если нет, можете воспользоваться нашей инструкцией по созданию хотспота).

Через Winbox сбросим настройки на дополнительном оборудовании: System — Reset configuration. В меню установите флажки No default configuration и Do not backup и нажмите Reset configuration.

После перезагрузки заново подключимся на дополнительный микротик и создадим бридж.

Добавим в созданный бридж (у нас – hs-bridge) интерфейс wlan1.

Откроем раздел Wireless и выберем опцию Setup Repeater. На открывшейся вкладке введем имя сети (SSID) с основного микротика и пароль этой сети (Passphrase) и нажмем Start.

Если ваша wi-fi сеть не имеет пароля (актуально для варианта с хотспотом), вам все равно потребуется в поле Passphrase прописать какой-либо пароль, в противном случае репитер попросту не сможет подключиться к сети основного оборудования. Пароль вы сможете убрать после установления связи между микротиками: настройки беспроводной сети, опция Security Profile, вместо созданного профиля wlan1-ВАШ_SSID-repeater выберите нужный (по умолчанию default).

После нажатия на Start дополнительный mikrotik подхватит сигнал с основного оборудования и отобразится в списке подключенных устройств на главном микротике (Wireless — Registration).

Настройка WDS на микротике

В качестве иного варианта работы беспроводной сети из нескольких микротиков рассмотрим WDS (Wireless Distribution System – беспроводная система распределения).

По такому же, как и в инструкции выше, принципу сбросим настройки дополнительного микротика, после чего создадим на нем новый бридж, в который добавим wlan1.

На основном микротике включим режим wds – для этого необходимо зайти в настройки wi-fi сети, выбрать вкладку WDS и указать Dynamic.

На дополнительном оборудовании откройте раздел Wireless, включите беспроводной интерфейс и в его параметрах в разделе Wireless выставьте mode – ap bridge, а в SSID пропишите название вашей беспроводной сети с основного Mikrotik.

В разделе wireless — WDS так же выберите параметр WDS mode — dynamic.

источник

Настройка MikroTik hAP mini как Wi-Fi Repeater

Сегодня я расскажу Вам, как настроить маленькую клиентскую точку MikroTik hAP mini.
Она будет подключаться к домашнему Wi-Fi и расширять зону действия Wi-Fi соединения.

Читайте также:  samsung smart tv настройка dlna

1. Вступление
Побывав в очередной раз на MUM в Москве. Мне опять посчастливилось получить в подарок такую штуку, как hAP mini
Снова был еще некоторый “Мерч”, что также очень приятно!

Давайте кратко рассмотрим само устройство.
Код продукта: RB931-2nD
Архитектура: SMIPS
CPU: QCA9533 (1 ядро, 650 MHz) – он же для Wi-Fi
Оперативной памяти: 32 Мб
Места на FLASH накопителе: 16 Мб
Температурный диапазон: от -20°C до +70°C
Максимальное потребление: 3.5Вт
Питание: microUSB type AB 5V(0,2A)
Wi-Fi: Каналов 2, Частота 2.4GHz, 802.11 b/g/n
Базовое усиление антенн: 1.5 dBi
Порты Ethernet: 3 по 10/100 Мбит/сек

Устройство компактное и его можно расположить скрытно, чтобы не мешало или установить наоборот на видное место, выглядит нормально.

MikroTik очень странные тесты описал. Они протестировали только три сетевых порта, которые выдали 296.3 Mbps на блоках 1518 байт. В общем странно, что нет теста Wi-Fi. Видимо маркетинговый ход.
Мои тесты в Btest(UDP, Random Data) для репитера показали такие значения:

Приступим непосредственно к настройке.

2. Настройка hAP mini
Я буду рассматривать подключение и раздачу Wi-Fi в своей домашней сети.
Создание домашней сети на базе устройств MikroTik: Часть 1
hAP mini должен подключиться к сети и далее работать в режиме репитера, для увеличения зоны покрытия частоты 2.4GHz. При подключении к репитеру не должно быть проблем с получением DHCP адресов от основного роутера.

Для начала подключим питание через USB порт и подключим hAP mini, сетевым кабелем к нашему ПК.
Запускаем уже привычный нам WinBox. (Для тех кто пропустил: Знакомимся с интерфейсом WinBox)
Находим наше устройство в Neighbors и подключаемся по MAC адресу.
Обновите hAP mini до последней версии прошивки из ветки Long-Term. На момент написания статьи у меня была версия 6.42.9

В статье затрагиваются списки интерфейсов, для которых написан отдельный материал: MikroTik RouterOS – Списки интерфейсов “Interface List”
Рекомендую ознакомиться перед тем, как приступить

2.1. Сброс базовых настроек
Консольно:
/system reset-configuration no-defaults=yes skip-backup=yes

После перезагрузки, подключаемся повторно по MAC адресу.
Я дополнительно устанавливаю пакет MULTICAST для его поддержки. Вы же, не обязаны этого делать.
Ставить или не ставить данный пакет решать Вам. Его можно найти, если скачать архив Extra packages с сайта MikroTik.
Он нужен если Вы решите пустить IPTV(igmp) трафик внутрь локальной сети не только по кабелям, но и по Wi-Fi.
Установка пакета выполняется простым перетаскиванием его в File List интерфейса WinBox и последующей перезагрузкой hAP mini.

2.2. Настройка проводных интерфейсов
Открываем вкладку Interfaces и переходим к настройке каждого интерфейса
У нас присутствует четыре интерфейса: ether1, ether2, ether3 и wlan1
Начнем с сетевых интерфейсов ether1, ether2, ether3:
Консольно:
/interface
set ether1 name=»LAN1-eth»
set ether2 name=»LAN2-eth»
set ether3 name=»LAN3-eth»

2.3. Настройка сетевого моста
Консольно:
/interface bridge
add name=»LAN-Bridge» comment=»LAN» mtu=1500 fast-forward=no igmp-snooping=yes protocol-mode=none

Создаем список интерфейсов и добавляем в него все сетевые интерфейсы
Консольно:
/interface list
add name=»Local»
/interface list member
add list=Local interface=LAN-bridge
add list=Local interface=LAN1-eth
add list=Local interface=LAN2-eth
add list=Local interface=LAN3-eth

Читайте также:  как сбросить настройки русь 27

Добавляем список интерфейсов в сетевой мост
Консольно:
/interface bridge port add interface=Local bridge=LAN-bridge

2.4. Настраиваем Wi-Fi для подключения к основной точке доступа
Создаем профиль с паролем от нашей основной Wi-Fi сети
Консольно:
/interface wireless security-profiles
add authentication-types=wpa2-psk eap-methods=»» management-protection=allowed mode=dynamic-keys name=gost supplicant-identity=»» wpa2-pre-shared-key=123456789

Настраиваем основной Wi-Fi интерфейс
Для настройки я использую расширенный режим “Advanced Mode”

А почему MODE = station-bridge ?
Я уже затрагивал данную тему в статье: Настройка MikroTik cAP Lite как Wi-Fi клиент в режиме Bridge
Потому решил отразить эту информацию и в данной статье.
Выдержка из: wiki.mikrotik.com – Wireless Station Modes: Mode_station
Матрица применимости:

802.11 ROS 802.11 nstreme nv2
station V V V V
station-wds V V V
station-pseudobridge V V V
station-pseudobridge-clone V V V
station-bridge V V V
  1. station
    Это стандартный режим, который не поддерживает прохождение L2 трафика – попытки установить беспроводной интерфейс в Bridge не приведут к ожидаемым результатам. С другой стороны, этот режим можно считать наиболее эффективным, и поэтому его следует использовать, если нет необходимости гонять L2 трафик через данного Wi-Fi клиента до конечных устройств или служб.
  2. station-wds
    Этот режим работает только с точками доступа RouterOS. В результате согласования соединения на AP для данной станции создается отдельный интерфейс WDS. Этот режим безопасен для прохождения трафика L2 и дает более гибкий административный контроль на точке доступа, к которой подключается клиент, с помощью отдельного интерфейса WDS, например, можно использовать межсетевой экран Bridge.
    В режиме station-wds невозможно подключиться к CAP, управляемой CAPsMAN!
  3. station-pseudobridge
    С точки зрения беспроводного соединения этот режим такой же, как и режим station. Он имеет ограниченную поддержку прохождения L2 трафика с помощью некоторых служб, реализованных на точке доступа, к которой подключается клиент.
    Суть данного режима в преобразовании MAC-адресов для пакетов IPv4. Wi-Fi клиент поддерживает таблицу сопоставления IPv4-MAC и заменяет исходный MAC-адрес своим собственным адресом при отправке кадра в точку доступа. Т.е. этот режим существенно ограничен.
    Доступен для всех протоколов, кроме nv2, и его следует по возможности избегать. Использование этого режима может быть оправдано только в том случае, если точка доступа не поддерживает лучший режим для моста L2 (например, когда используется точка доступа, отличная от RouterOS) или если только одно устройство конечного пользователя должно быть подключено через Wi-Fi клиент.
  4. station-pseudobridge-clone
    Этот режим аналогичен режиму station-pseudobridge, за исключением того, что он подключается к точке доступа с использованием «клонированного» MAC-адреса – это либо адрес, настроенный в параметре station-bridge-clone-mac, либо адрес источника первого перенаправленного кадра.
  5. station-bridge
    Этот режим работает только с точками доступа работающих под управлением RouterOS. Он обеспечивает поддержку прозрачную, независимую от протокола, пересылку трафика L2.
    В этом режиме, точка доступа, поддерживает таблицу пересылки с информацией о том, какие MAC-адреса доступны и через какие Wi-Fi клиенты.
    Этот режим является собственностью MikroTik и не может использоваться для подключения к устройствам других марок.
    Этот режим безопасен для пересылки L2 трафика и является предпочтительным режимом, если нет особых причин использовать режим station-wds.
    В режиме station-bridge невозможно подключиться к CAP, контролируемой CAPsMAN!
Читайте также:  настройка передачи данных на сервер

Я решил использовать полноценный функционал прохождения L2 трафика в режиме station-bridge т.к. подключил Wi-Fi клиента к роутеру MikroTik hAP ac, работающему на RouterOS.

Консольно:
/interface wireless
set [find default-name=»wlan1″] name=»LAN4-wifi24ghz» adaptive-noise-immunity=ap-and-client-mode band=2ghz-onlyn channel-width=20/40mhz-XX country=romania disabled=no distance=indoors frequency=auto frequency-mode=regulatory-domain hw-protection-mode=rts-cts mode=station-bridge multicast-helper=full radio-name=POINT_24 security-profile=gost ssid=POINT_24 wireless-protocol=802.11 wmm-support=enabled hw-retries=15 disconnect-timeout=15s on-fail-retry-time=1s

Для подключения к основной сети используем раздел подключений “Connect List”
Консольно:
/interface wireless connect-list
add interface=LAN4-wifi24ghz security-profile=gost ssid=POINT_24 wireless-protocol=802.11

В этом месте уже должно произойти подключение к нашей основной точке доступа, но hAP mini не получит IP адрес и не выйдет в интернет, а также пока что не будет выступать в роли именно репитера.
Давайте исправим это недоразумение.

2.5. Настраиваем Wi-Fi для трансляции той же сети
Создаем виртуальный Wireless интерфейс
Консольно:
/interface wireless
add disabled=no master-interface=LAN4-wifi24ghz multicast-helper=full name=LAN4-1-wifi24ghz security-profile=gost ssid=POINT_24 wds-cost-range=0 wds-default-cost=0 wmm-support=enabled wps-mode=disabled

Не забываем добавить наши Wireless интерфейсы в список Local и они автоматически добавятся в сетевой мост LAN-bridge
Консольно:
/interface list member
add list=Local interface=LAN4-wifi24ghz
add list=Local interface=LAN4-1-wifi24ghz

Если все настроили корректно, то наши устройства уже смогут подключаться к Wi-Fi сети организованной репитером. Ведь он транслирует абсолютно такой же SSID.

3. Дополнительно
Если Вам необходимо, чтобы репитер имел выход в интернет, например для автоматического обновления прошивки или еще каких-либо действий, то необходимо включить DHCP клиент или настроить параметры вручную.
Вариант 1, через DHCP Client
После добавления правила, репитер автоматически получит IP адрес, DNS адрес и установит дефолтный маршрут согласно настроенному DHCP серверу на основном роутере
Консольно:
/ip dhcp-client
add interface=LAN-bridge default-route-distance=1 disabled=no add-default-route=yes use-peer-dns=yes use-peer-ntp=yes

Вариант 2, через ручную настройку
Также можно все операции, которые делаются автоматически через DHCP клиент, проделать вручную.
Основным плюсом этого является, что если репитеру недоступен головной роутер, он будет иметь свой фиксированный IP адрес.
Добавляем IP адрес вручную Консольно:
/ip address add interface=LAN-bridge address=192.168.88.26/24

Добавляем DNS адрес вручную Консольно:
/ip dns set servers=192.168.88.1 Добавляем дефолтный маршрут для выхода в интернет Консольно:
/ip route add dst-address=0.0.0.0/0 gateway=192.168.88.1 check-gateway=ping

Данных настроек должно быть достаточно, чтобы у Вас все работало, как надо.
Остальное по желанию (sntp, snmp, scripts, и т.д)
К сожалению информации по используемому модулю Swich чипа нет в официальной Wiki MikroTik, хотя обозначение Bridge Hardware Offloading на интерфейсах есть.

Большое спасибо, что изучили данную статью, надеюсь она Вам помогла узнать больше!

Всего хорошего на просторах интернета 😉

Список всех статей в хронологическом порядке: История статей

UPD 30.11.2018
Добавлены настройки в Wireless Advanced для уменьшения кол-ва переподключений (data loss)

UPD: 30.11.2019
Добавлена информация по выбору Mode на вкладке Wireless. Почему все таки station-bridge?

источник

Adblock
detector