Меню

dhcp сервер настройка на микротике

Для начинающих:Настройка DHCP-сервера

Содержание

Введение

Есть два способа создания DHCP-сервера на маршрутизаторах MikroTik:

  1. С помощью мастера создания DHCP-сервера
  2. Пошаговая настройка каждого элемента

Мы предпочитаем использовать второй способ, т. к. он предоставляет возможности более тонкой настройки.

Через графический интерфейс

Создание пула адресов. Первым делом надо создать пул адресов из которого будут раздаваться адреса в аренду. Выберем диапазон: 192.168.15.101 — 192.168.15.200

Создание DHCP-сервера. Далее создадим сам DHCP-сервер, укажем для него созданный на предыдущем шаге пул, укажем срок аренды три дня и выберем интерфейс с которого будут раздаваться адреса.

Примечание: Обратите внимание, что в вашей сети может использоваться другой интерфейс.

Задание настроек. И в конце зададим настройки, которые должен раздавать наш DHCP-сервер: шлюз, DNS и WINS-серверы.

Через консоль

/ip pool
add name=dhcp-pool1 ranges=192.168.15.101-192.168.15.200

/ip dhcp-server
add address-pool=dhcp-pool1 disabled=no interface=ether1-LAN1 lease-time=3d name=dhcp-server1

/ip dhcp-server network
add address=192.168.15.0/24 dns-server=192.168.15.10 gateway=192.168.15.1 netmask=24 wins-server=192.168.15.10

Проверка

Проверка работоспособности DHCP-сервера простая. Достаточно подключиться компьютером к заданному интерфейсу. Выставить в его настройках получение IP-адреса с помощью DHCP-сервера. И проверить получены ли заданные нами настройки.

источник

ИТ База знаний

Полезно

— Узнать IP — адрес компьютера в интернете

— Онлайн генератор устойчивых паролей

— Онлайн калькулятор подсетей

— Калькулятор инсталляции IP — АТС Asterisk

— Руководство администратора FreePBX на русском языке

— Руководство администратора Cisco UCM/CME на русском языке

— Руководство администратора по Linux/Unix

Навигация

Серверные решения

Телефония

Настройка программных телефонов

Корпоративные сети

Популярное и похожее

Настройка PPTP клиента на Mikrotik

Мониторим MikroTik с помощью Zabbix по SNMP

Умная защита от атак MikroTik

Graphings: графики в MikroTik

Настройка DHСP сервера на Mikrotik

Как часть Auto provisioning`а для телефонов

Привет! В сегодняшней статье хотим рассказать о том, как настроить DHCP сервер для организации офисной IP-телефонии. Этой темы мы уже косвенно касались в нашей прошлой статье, а сегодня покажем всё на практике. Мы будем использовать роутер MikroTik RB951Ui-2HnD с операционной системой MikroTik RouterOS 6.35.4, но для этих целей подойдёт абсолютно любое устройство, поддерживающее данный сервис.

Настройка DHCP

Итак, открываем WinBox и подключаемся к нашему роутеру, далее переходим во вкладку IPPool+:

Открывается следующее окно:

Обозначим диапазон IP адресов, которые будем раздавать подключаемым телефонам, например, 192.168.1.10 – 192.168.1.100.

Теперь настроим непосредственно DHCP-сервер, который будет раздавать адреса из созданного пула телефонам, для этого переходим по пути IPDHCP ServerDHCP+:

Открывается следующее окно:

В данном окне необходимо указать интерфейс, с которого наш сервер будет раздавать адреса (в нашем случае – ether1), Lease Time — время, на которое будет выдан адрес (в нашем случае – 1 день) и, собственно, пул адресов (Address Pool), которые могут быть выданы (в нашем случае – dhcp, который мы создали ранее)

Option 66

А теперь самое важное, для чего, всё это затевалось — Опция 66. Опция 66 (option 66) – это аналог проприетарной опции 150 (option 150), разработанной компанией Cisco для автоматического обновления прошивок и конфигурации (Auto Provisioning) телефонов Cisco IP Phone. Данная опция содержит в себе адрес TFTP сервера, на который должен обратиться телефон, чтобы скачать прошивку и файл с конфигурацией, как только подключается к сети. Единственным различием между опцией 150 и 66, является то, что благодаря опции 150 можно указывать IP адреса для нескольких TFTP серверов, а в опции 66 можно указать только один адрес. Опция 66 является открытым стандартом IEEE, который поддерживается большинством производителей роутеров и VoIP-оборудования. Описывается в RFC 2132.

Читайте также:  настройка ближнего света меган 2

Давайте её настроим, для этого переходим на вкладку Options+ и видим следующее окно:

Важно! Прежде чем вводить IP адрес TFTP сервера в поле Value, проверьте версию RouterOS, от этого будет зависеть синтаксис данной настройки.

  • Для версий с 6.0 -6.7, значение IP адреса нужно вводить, используя одинарные ковычки — ’192.168.1.1’
  • Для версий от 6.8, значение IP адреса нужно вводить, используя следующий синтаксис — s’192.168.1.1’

  • Name — Название новой опции
  • Code — Код опции по RFC 2132
  • Value — IP адрес TFTP сервера, на котором лежат прошивки для телефонов
  • Raw Value — 16-ричная интерпретация IP адреса TFTP сервера, рассчитывается автоматически после нажатия кнопки Apply

Готово, теперь переходим на вкладку Network и указываем только что настроенную опцию 66 как показано ниже:

Итак, теперь, как только мы подключим новый телефон в сеть, он получит по DHCP адрес из пула 192.168.1.10- 100, а также адрес TFTP сервера в опции 66, на котором для него лежит конфигурационный файл и актуальная версия прошивки.

Полезна ли Вам эта статья?

Пожалуйста, расскажите почему?

😪 Нам жаль, что статья не была полезна для вас 🙁 Пожалуйста, если не затруднит, укажите по какой причине? Мы будем очень благодарны за подробный ответ. Спасибо, что помогаете нам стать лучше!

😍 Подпишитесь на нашу еженедельную рассылку, и мы будем присылать самые интересные публикации 🙂 Просто оставьте свои данные в форме ниже.

источник

Как настроить DHCP сервер на маршрутизаторе Mikrotik

Для того что бы устройства подключенные в локальную сеть могли получать ip адреса автоматически, необходимо настроить DHCP сервер.

Быстрая настройка

Подключаемся к маршрутизатору через winbox. Открываем вкладку IP->DHCP Server. В появившемся окне, во вкладке DHCP нажимаем кнопку DHCP Setup.

Откроется следующее окошко

Здесь мы выбираем локальный интерфейс, на котором будет работать ЛВС, если интерфейсы объединены в bridg то выбираем этот бридж.

Также если необходимо настроить сервер на vlan, то выбираем нужный vlan. После выбора интерфейса нажимаем Next. В следующем окне вводим нашу локальную сеть.

Прописываем шлюз по умолчанию который будет выдаваться клиентам.

На следующей странице прописываем DHCP Relay. Relay-это ip DHCP сервера, если бы у нас в качестве сервера выступал бы другой Микротик или отдельный компьютер, то здесь нужно было бы прописать его ip. У нас маршрутизатор Mikrotik является server, поэтому Relay нам не нужен и мы просто нажимаем стрелку вверх справа от окошка ввода.

Выбираем пул диапазона range ip адресов, которые будут выдаваться клиентам.

Здесь будут выдаваться ip с 10.10.10.2 по 10.10.10.254

Читайте также:  настройка тнвд gdi 4g93

В следующем окне вводим DNS сервера, если в Микротике настроено кэширование ДНС, то вводим ip роутера.

Или другие ДНС, для добавления ДНС нажмите стрелку вниз с левой стороны от окна ввода.

Нажимаем Next. Осталось указать время аренды ip адресов Lease Time.

В примере ip будут выдаваться на один день, т.е. 24 часа. Можно сделать аренду 72 часа, для этого введите строку 3d 00:00:00.

Нажимаем Next. Если все сделали правильно, то появится окошко.

После нажатия кнопки в списке DHCP появится созданный сервер, Если что, то настроено не правильно, строка будет гореть красным цветом.

Например, если на порту не настроен ip адрес.

На этом быстрая настройка сервера Микротик закончена. Таким образом, можно настроить несколько серверов для разных пулов. Например, настроить два DHCP, один будет выдавать адреса для пользователей, а другой для локальных ресурсов внутри сети.

Дополнительные настройки DHCP сервера.

Для дополнительных настроек кликните два раза по созданному серверу, в результате откроется окно где можно изменить или добавить дополнительные настройки.

Рассмотрим настраиваемые здесь опции.

Name-Любое имя

Interface – сетевой интерфейс на котором настроен сервер, может быть как физическим так и vlan или bridge.

Lease Time Время аренды ip, по истечении которого сетевому устройству будет выдан новый.

Address Pool диапазон из которого будут выдаваться ip для сетевых устройств, настраивается в IP->Pool.

Src.Address используется если на интерфейсе настроено несколько ip, здесь прописываем рабочий DHCP.

authoritative принимает следующие параметры

yes — если клиент запросит IP, Микротик ему сразу же ответит. Причём если устройство ранее получало IP другого DHCP в сети, то Микротик пошлёт ему пакет DHCPNAK заставляющий обновить ему свой IP

No — если клиент ранее получавший IP с другого DHCP запросит адрес у Микротика то он его проигнорирует

After 2s delay — если клиент запросит IP недоступный на Mikrotik он будет его игнорировать 2 секунды, а далее пошлёт DHCPNAK и присвоит IP из своего диапазона. Своим клиентам Микротик отвечает мгновенно.

After 10s delay — если клиент запросит IP адрес недоступный на Mikrotik он будет его игнорировать 10 секунд, а далее пошлёт DHCPNAK и присвоит IP адрес из своего диапазона. Своим клиентам Микротик отвечает мгновенно.

Bootp Support принимает значения

none — не реагировать на запросы BOOTP

static — предлагать только статические лизинг для BOOTP

dynamic — предлагать статическую и динамическую аренду для BOOTP

leasescript в этом окне можно добавить исполняемый скрипт, например при подключении компьютера заносить всю информацию в лог.

add arp for leases — автоматически заполняет ARP таблицу, соответствием MAC — IP.

always broadcast — Всегда отправляйте широковещательные пакеты, даже если IP-адрес назначения известен. При включении этой опции возможна дополнительная нагрузка на сеть L2.

Use Radius — Указывает использовать ли RADIUS server для аккаунтинга и аренды адресов.

На Вкладке Networks, кликаем два раза по созданному серверу и рассмотрим опции.

Address – здесь все понятно, ip Микротика

Читайте также:  asus g32 настройка rdp

Gateway – шлюз выдаваемый сетевым устройствам

Netmask – маска сети

DNS Servers – ДНС выдаваемые сетевым устройствам

Domain – Имя домена сети

Boot File Name имя загрузочного файла, используется если включена загрузка по сети через tftp.

Options – дополнительные опции, как настроить рассмотрим ниже.

Привязка клиентов по MAC адресу

Если необходимо что бы клиент получал всегда один и тот же ip, то можно зарезервировать ip адрес за MAC адресом, для этого переходим во вкладку IP->DHCP Server, в открывшемся окне выбираем вкладку Leases, у нас откроется список клиентов.

Кликаем левой кнопкой мыши по нужной записи и нажимаем кнопку Make Static.

После этого буква D напротив этого клиента должна исчезнуть.

Теперь MAC клиента будет привязан к постоянному ip.

На этой вкладке также можно узнать и о статусе подключенных пользователей

waiting — пользователь не в сети, ожидается подключение.

testing — проверка использования этого адреса или нет (только для динамической аренды) путем опроса его с тайм-аутом 0,5 с

authorizing — ожидание ответа от сервера радиуса

busy — этот адрес назначается статически клиенту или уже существует в сети, поэтому он не может быть арендован, например если на компьютере настроить ip вручную.

offered — сервер предложил адрес пользователю, но не получил подтверждение от пользователя.

bound — адрес назначен пользователю и используется, будет освобожден по истечении времени аренды.

Настройка options

Если необходимо настроить опции, например option 82 использующаяся для привязки IP к порту, или option 66 указывающая ip tftp сервера.

Для настройки переходим на вкладку «Options» и жмем кнопку добавить (красный крест)

Заполняем поля открывшегося окошка.

Name-название, вводим любое имя

Code – код опции, 66, 82 и т.д.

Value – адрес ресурса, например tftp сервера

Важно: проверьте версию RouterOS, от этого будет зависеть синтаксис данной настройки.
Для версий с 6.0 -6.7, значение IP нужно вводить, используя одинарные ковычки — ’10.10.10.10’
Для версий от 6.8, значение IP нужно вводить, используя следующий синтаксис — s’10.10.10.10’

После нажатия кнопки Apply полу Raw Value заполнится автоматически, жмем OK, должна появится строчка нашей опции

Теперь переходим вкладку «Networks» и два раза кликаем по нужному серверу.

В открывшемся окне, в пункте Options, выбираем нужную нам опцию, созданную на первом шаге. После чего нажимаем кнопку ОК и настройка опции на этом закончена.

Обучающий курс по настройке MikroTik

Нужно разобраться с MikroTik, но не определились с чего начать? В курсе «Настройка оборудования MikroTik» все по порядку. Подойдет и для начала работы с этим оборудованием, и для того, чтобы систематизировать знания. Это видеокурс из 162 уроков и 45 лабораторных работ, построен на официальной программе MTCNA. Проходить можно, когда удобно и пересматривать по необходимости – материалы курса выдаются бессрочно. Также есть 30 дней на личные консультации с автором. На пробу выдают 25 уроков бесплатно, заказать их можно на странице курса.

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

источник

Добавить комментарий

Adblock
detector