Меню

dhcp настройка привязка к mac

Dhcp настройка привязка к mac

Всех приветствую.
Проблема такая настраиваю DHCP чтобы он выдавал IP по MAC. Кучу всего исчитал, вроде все правильно пишу. НО. не хочет клиент получать свой фиксированный IP. Ниже конфигурация.Если не трудно ткните носом что не так делаю

Current configuration : 3465 bytes

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 $1$y0sC$6d7P/VHmkgq7GUL4mY7Zk.
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-1763720374
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1763720374
revocation-check none
rsakeypair TP-self-signed-1763720374
!
!
dot11 syslog
no ip dhcp use vrf connected
ip dhcp binding cleanup interval 600
ip dhcp excluded-address 10.10.0.1 10.10.10.99
ip dhcp excluded-address 10.10.10.201 10.10.255.254
!
ip dhcp pool sdm-pool1
import all
network 10.10.0.0 255.255.0.0
default-router 10.10.10.1
!
ip dhcp pool DG
host 10.10.10.201 255.255.0.0
client-identifier 0100.19db.5f2e.05
!
!
ip cef
ip name-server IP1
ip name-server IP2

!
username admin privilege 15 password 0 password

!
archive
log config
hidekeys
!
ip rcmd rsh-enable
ip rcmd remote-host shilvlad 10.10.10.100 shilvlad enable
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description $ES_WAN$
ip address dhcp client-id FastEthernet4
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
ip address 10.10.10.1 255.255.0.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 100 interface FastEthernet4 overload
ip nat inside source static tcp 10.10.10.100 25309 94.137.66.12 25309 extendable
!
access-list 100 remark SDM_ACL Category=2
access-list 100 permit ip 10.10.0.0 0.0.255.255 any
!
control-plane
!
line con 0
password cisco
no modem enable
line aux 0
line vty 0 4
privilege level 15
password cisco
login local
transport input telnet ssh
!
scheduler max-task-time 5000
end

>[оверквотинг удален]
> no modem enable
>line aux 0
>line vty 0 4
> privilege level 15
> password cisco
> login local
> transport input telnet ssh
>!
>scheduler max-task-time 5000
>end

conf t
no ip dhcp excluded-address 10.10.10.201 10.10.255.254

поможет если мак пральный прописали.

1. «Настройка dhcp для привязки IP к MAC» + / –
Сообщение от mario (ok) on 15-Окт-09, 17:51
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. «Настройка dhcp для привязки IP к MAC» + / –
Сообщение от serega3333 (??) on 17-Окт-09, 17:21

>[оверквотинг удален]
>> login local
>> transport input telnet ssh
>>!
>>scheduler max-task-time 5000
>>end
>
>conf t
>no ip dhcp excluded-address 10.10.10.201 10.10.255.254
>
>поможет если мак пральный прописали.

Так оно и есть. Адреса выдает DHCP, настроен DHCP, который определенному мак адресу выдает указанный IP адрес и выше в правилах эта сетка исключается из пула DHCP адресов

может не истекло время лизинга предыдущего адреса, полученного через дхцп, потому статичный дхцп не выдается?

команда
# clear ip dhcp binding 10.10.10.201
очистит старый адрес дхцп. и будет выдан новый.

посмотреть выделенные адреса можно командой
# show ip dhcp binding.

источник

Использование DHCP или ввод IP-адреса вручную на Mac

IP-адрес — это номер, идентифицирующий каждый компьютер в Интернете или сети. Когда Вы подключаетесь к Интернету или IP-сети, компьютеру требуется IP-адрес.

Есть два основных способа, с помощью которых можно задать IP-адрес.

Автоматически: Вашему компьютеру назначается адрес с помощью протокола DHCP.

Вручную. Ваш интернет-провайдер или сетевой администратор предоставляет IP-адрес, который необходимо ввести на панели «Сеть» в Системных настройках.

Выполните описанные ниже действия, чтобы ввести свой IP-адрес или назначить его автоматически.

На Mac выберите меню Apple > «Системные настройки», затем нажмите «Сеть».

Выберите сетевое подключение, которое хотите использовать, в списке (например, Ethernet).

Нажмите всплывающее меню «Конфигурация iPv4» и выберите нужный вариант:

Если Ваш адрес назначается автоматически, выберите «Использовать DHCP».

Если интернет-провайдер или администратор предоставил Вам IP-адрес, выберите «Вручную» и введите адрес в поле «IP-адрес». Поставщик услуг сети Интернет предоставляет DHCP-адрес вместе с прочей информацией, например маской подсети, маршрутизатора и сервера DNS (служба доменных имен). Укажите маску подсети и маршрутизатор в соответствующих полях. Чтобы ввести адрес DNS-сервера, нажмите «Дополнительно», откройте вкладку «DNS», затем нажмите кнопку и введите адрес.

Примечание. Большинство IP-адресов — это адреса IPv4, которые выглядят как серия чисел, разделенных тремя точками, например: 123.45.67.89. Если Вы получили IP-адрес с более длинной последовательностью чисел и букв, разделенных семью точками (например, fa80:0000:0000:0123:0203:93ee:ef5b:44a0), то это другой тип IP-адреса, который называется IPv6. Чтобы ввести адрес IPv6, в разделе настроек «Сеть» нажмите «Дополнительно». В TCP во всплывающем меню «Конфигурация IPv6» выберите «Вручную» и введите адрес IPv6.

источник

Настраиваем фильтрацию MAC-адресов в DHCP Windows Server

В Windows Server 2012/2016/2019 и ранее, имеется прекрасная возможность разрешать и запрещать определенным сетевым устройствам по их MAC-адресам использовать корпоративный DHCP сервер.

Данная возможность предназначена для того, чтобы запретить неизвестным устройствам получение IP адреса и других настроек с сервера DHCP. Данная возможность реализуется путем создания списка запрещенных адресов (Block List) и/или разрешенных адресов (Allow list).

Для начала нужно запустить оснастку DHCP

Далее выбираем пункт IPv4 и правой кнопкой мыши вызываем меню «Свойства»

В открывшемся окне выбираем вкладку Фильтры и ставим галочку на пункте «Включить список запрещенных»

MAC адреса сетевых устройств добавляются и удаляются вручную в DHCP с помощью контекстного меню Добавить к фильтру — Запретить. И в дальнейшем все блокированные MAC-адреса будут храниться разделе Фильтры — Запретить, как показано на рисунках ниже.

Данный способ совсем не является панацеей, однако сделает нашу сеть немного более контролируемой, что тоже хорошо :))

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter .

источник

Жёсткая привязка IP к MAC адресу для качественной защиты

Достаточно просто и легко

Сначала разберёмся немного с теорией.

MAC-адрес- это уникальный идентификатор устройства, состоящий из 48-ми бит. Такой адрес имеют абсолютно все гаджеты способные выходить в интернет.

Но он не привязан намертво к изделию.Сменить его не составляет никакого труда.Зная только IP невозможно связаться с устройством.Обязательно требуется знать и MAC-адрес.

ARP-протокол, который сопоставляет IP и MAC.

Но у данного протокола существует определённая уязвимость.Эта уязвимость может позволить сильно любопытному просматривать ваши соединения.

Но при обязательном условии, что он находится в одной с вами локальной сети. Называется такая атака

Сегодня мы разберём не саму атаку и методы её проведения, а наоборот.Я хочу показать достаточно простой и эффективный метод защиты от такого рода посягательств.

При подключении компьютера к сети он посылает запрос роутеру, на основе этих запросов и ответов создаётся ARP таблица.Таблица сохраняется до перезагрузки или выключения.

Для того, чтобы посмотреть данную таблицу необходимо запустить командную строку(от имени администратора) и прописать такую команду

На этом примере можете видеть, что mac-адрес динамический.Если закрепить данный адрес статически, то атака станет невозможной.

Для этого в командной строке необходимо прописать следующее

Но данная команда не всегда срабатывает.Если не сработала, то пишем другую

netsh interface ipv4 add neighbors «Ваш тип подключения» «IP вашего роутера» «мас адрес»

. Обязательно посмотрите как указан ваш тип подключения в центре управления сетями и общим доступом, и именно так впишите.

Всё удачно. Теперь у нас статический MAC-адрес.Но может возникнуть неудобство.А именно, если заменить роутер на другой(надоел старый), то подключиться не получиться.

Надо будет вернуть динамический адрес.Для этого прописываем команду

netsh interface ipv4 del neighbors «Ваш тип подключения» «IP вашего роутера» «мас адрес»

Вот и всё. Как могли убедиться ничего сложного нет.А между тем такие простые действия обеспечат качественную защиту.

Надеюсь, что было познавательно.

Благодарю всех за уделённое время и внимание.

Не поленитесь оценить лайком и подпиской.

источник

Читайте также:  android для установки на персональный компьютер

Как настроить и установить? © 2022
Все права сохранены © 2020. Информация, опубликованная на сайте, носит исключительно ознакомительный характер и не является рекомендацией к применению. Внимание! Материалы могут содержать информацию, предназначенную для пользователей старше 18 лет. 18+

Adblock
detector